Versión mínima de PHP para WordPress

Última revisión: 24 de noviembre de 2020

Desde hace unas pocas versiones de WordPress, todos aquellos desarrolladores de plugins pueden indicar la versión mínima de PHP necesaria para que funcione. WordPress está poniendo muchos esfuerzos en mantener al día y con unas versiones actualizadas todos sus productos y servicios, y eso implica a los propios desarrolladores, tal y como se informó en agosto de 2017.

La idea es que en la cabecera del plugin se indique con una línea la versión mínima:

=== Plugin Name ===
Contributors: (this should be a list of wordpress.org userid's)
Donate link: http://example.com/
Tags: comments, spam
Requires at least: 4.6
Tested up to: 4.8
Requires PHP: 5.6
Stable tag: 4.3
License: GPLv2 or later
License URI: https://www.gnu.org/licenses/gpl-2.0.html

En este caso, se indica el texto Requires PHP: 5.6 en el que se informa que la versión mínima de funcionamiento del plugin es 5.6; por lo tanto, aquellos usuarios que tengan versiones anteriores de PHP en su sistema recibirán un aviso conforme puede no funcionar o directamente bloquear la posible instalación.

En el repositorio de plugins, además, aparecerá un aviso de la versión en la zona de información técnica.


Seguir con Seguridad para WordPress


Sobre este documento

Este documento está regulado por la licencia EUPL v1.2, publicado en WP SysAdmin y creado por Javier Casares. Por favor, si utilizas este contenido en tu sitio web, tu presentación o cualquier material que distribuyas, recuerda hacer una mención a este sitio o a su autor, y teniendo que poner el material que crees bajo licencia EUPL.

Servicios de Administración de Sistemas WordPress

¿Tienes un sitio web con WordPress de alto tráfico? ¿Eres una Agencia con servidores con cPanel, Plesk u otro panel en los que mantienes WordPress para tus clientes?

Si es así y te interesa un servicio profesional de mantenimiento de infraestructura WordPress y de mejora del rendimiento de tus sitios web o los de tus clientes, contacta conmigo.